Check workflows API v2 compatibility

The Collibra Command Line Interface allows you to scan your workflows and detect any usage of API v1 in them.

Example   workflow-analyze

The tool scans by default the workflows from the environment configured via collibra-set. Optionally, you can provide the path to a local file or directory to be analyzed.

The output is an HTML report with a diagnostic for each scanned workflow. The diagnostic highlights potential issues in the namespace, the delegates, the listeners and your scripts.

Note    The analysis also checks if the Groovy code can be parsed by Groovy3, which is part of Collibra starting with release 2021.10. If you only want to find the Groovy3 parsing problems, add the groovySyntaxErrorsOnly option.

For each issue, the tool suggests a solution to help you migrate your workflow definition to API v2.

Command

workflow-analyze

Description

Options

Output

Scans one or more workflows and generates a report with issues related to API v1 usage.
  • --path or -p

    The local path to a BPMN file or a directory containing BPMN files to be analyzed.

  • --outputDirectory or -o

    The output directory of the generated report. By default $HOME/.collibra-cli

  • --groovySyntaxErrorsOnly or -g

    Recognize only syntax errors in Groovy scripts.

  • The number of BPMN files analyzed.
  • The number or BPMN files including API v1 references.
  • A link to the generated report.

Example of a workflow compatibility report: